
Network License Administrator’s
Guide

The following instructions are for administrators at sites with a network license for IBM® SPSS®
Statistics 19. This license allows you to install SPSS Statistics on any number of computers.
However, only the number of users for which you purchased the license can run the application
concurrently.

Before You Start
You will need the authorization code that was included (on a separate sheet of paper) with your
system. This enables you to get a license for the network license manager. The network license
manager controls your network license and allows end users to run IBM® SPSS® Statistics. If
you cannot find your authorization code, contact your sales representative.

To ensure that you set up the network license correctly, follow these steps:

E Install the network license manager. The network license manager is the utility that will serve
up the network licenses to end users. You can install the license manager on any computer on
your network. This is typically a server to which desktop computers can connect. For more
information, see the topic Installing the Network License Manager on p. 2 .

E License your product. This action will give the license manager the required information for
serving up the licenses. For more information, see the topic Licensing Your Product on p. 5 .

E Test the network license manager. You should test license manager to make sure it is serving up
licenses. For more information, see the topic Testing the License Manager on p. 9 .

E Install SPSS Statistics on the local desktop computers. You or your end users will complete the
full installation on the desktop computers. During an installation, an end user can specify the
computer on which the license manager is running. When an end user tries to launch SPSS
Statistics, the product communicates with this license manager to get a license. If a license is
available, SPSS Statistics launches. For more information, see the topic Installing the Product
on the Local Desktop Computers on p. 9 .

No administration steps are required for the installation, but if any problems arise, see
Administering the Network License on p. 15.

Ghosting

You can ghost the software by installing the license manager and then installing the product on a
local desktop that will be used for creating the ghosting image. Ghost the additional computers
as needed.
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Citrix and Terminal Services

You can install and publish the IBM® SPSS® Statistics application on your Citrix or Terminal
Services Server the same way that you install and publish other Windows applications.

Mixed Licensing

IBM® SPSS® Statistics has limited support for a mixed licensing environment (a combination of
local and network licenses). In a typical environment, all licenses are handled locally or through
the network license manager. For example, if the main product is licensed through the network
license manager, add-on modules are also licensed through the network license manager.

The only option for mixed licensing is to license the main product through the network license
manager and to license the add-on modules on the end user’s computer with licenseactivator. To
set up this type of mixed licensing, install SPSS Statistics with a network license. Then use
licenseactivator on the end user’s computer to license the add-on modules. For more information
about licenseactivator, see Using licenseactivator to Install a License Automatically on p. 6 .

SPSS Statistics does not support the opposite scenario to license the main product locally and to
license the add-on modules through the network license manager.

Installing the Network License Manager

Before end users install IBM® SPSS® Statistics on their desktop computers, you must install
the network license manager. This utility is a continuously executing service or daemon that you
will typically install on one computer on your network. (You also have the option of installing
on multiple computers, in which case you would set up redundant license managers. For more
information, see the topic Setting Up Redundant License Servers on p. 16.) You do not install the
network license manager on the desktop computers.
Whenever an end user starts a network-licensed SPSS Inc. application, the application will

request a license from the license manager. This utility will deliver licenses up to a fixed number
of simultaneous end users, determined by the license that you have purchased. After this number
has been met, any further requests for licenses will be refused. If you find that end users are
often being refused licenses, you can contact your sales representative to purchase a license that
will allow more simultaneous users.

Note: The license manager will record the number of active end-user sessions and information
about each session in a log file, which you can use to troubleshoot connection problems. For more
information, see the topic Setting the Location of the Log File on p. 16.

Multiple Operating Systems

The platform on which the network license manager is running does not have to match the
platform on which the client is running. For example, a Linux license manager can serve up
licenses for Windows clients.
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The DVD includes a license manager for the same platforms on which SPSS
Statistics runs. If available, license managers for other platforms can be found at
http://support.spss.com/ProductsExt/Shared%20Utilities/Sentinel/download.html.

Administering the License Manager

You administer the license manager using the license manager tools, which are available only
for Windows. Therefore, you need at least one Windows machine on which to install the license
manager tools.

System Requirements

The computer on which you install the network license manager must meet the following
requirements:

550 Mhz or higher processor
128 MB of RAM or more

Important! If a firewall is running on the license server, you must open port 5093 for UDP.
Otherwise, client computers will not be able to retrieve a license from the license manager.
Furthermore, if you are using redundant license servers, you must open port 5099 for UDP to
enable the license servers to communicate with each other.

Upgrading the License Manager

If you have a previous version of the license manager installed, you must perform the following
steps:

E Go to the directory in which you installed the old license manager.

E Copy the lservrc file. On Windows, look in the winnt subdirectory.

E Save the lservrc file to a safe location.

E If any users have checked out commuter licenses, make sure those users check the licenses back
in. See the topic Configuring Commuter Licenses on p. 18 for information about obtaining a
list of checked out licenses.

E Shutdown the license manager. For more information, see the topic Starting and Stopping the
License Manager on p. 21.

E Install the new license manager. Do not install in the same directory in which the previous
version of the license manager is installed. For information about installing on Windows, see the
topic Installing the License Manager on a Windows Machine on p. 4 . For information about
installing on other operating systems, see the topic Installing the License Manager on Other
Operating Systems on p. 4 .

E Copy the saved lservrc file to the directory in which you installed the new license manager or
the winnt subdirectory of the installation directory on Windows. If you accepted the default

http://support.spss.com/ProductsExt/Shared%20Utilities/Sentinel/download.html
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location on Windows, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder.

E After starting the new license manager, you can safely uninstall the old license manager. For more
information, see the topic Uninstalling the License Manager on p. 22.

Installing the License Manager on a Windows Machine
Note: On Windows Vista or 7, you must launch the installer as administrator. When instructed to
launch an installer file, right-click the file and choose Run As Administrator.

E Insert the DVD into the DVD drive of the network computer on which you want to run the license
manager. Launch \Windows\Administration\Licensing\NetworkLicenseManager\setup.exe from
the DVD.

or

E If you downloaded the license manager, use an archive utility such as WinZip to extract the
contents of the downloaded file. Launch the setup.exe file.

E Follow the instructions that appear on the screen.

Installing the License Manager on Other Operating Systems

E Insert the DVD into the DVD drive of the network computer on which you want to run the license
manager.

E Browse to <operating system>/Administration/Licensing/NetworkLicenseManager on the DVD.

or

E Browse to the location where you downloaded the license manager.

E Untar the file that corresponds to the machine’s platform.

E Install the license manager tools on a Windows machine. For more information, see the
topic Installing the License Manager Tools on p. 4 .

E Refer to Starting and Stopping the License Manager on p. 21 for information about starting
the license manager.

Installing the License Manager Tools

The Windows-only license manager tools are used to administer the license manager. Depending
on your operating system, you may need to manually install these tools.

Windows. The tools are installed automatically with the license manager on a Windows
machine, so you can skip installation if you are using only Windows license managers. You
also have the option of installing on another Windows machine if you want to administer the
license manger remotely.
Other Operating Systems. If you installed the license manager on a non-Windows machine, you
must install the license manager tools on a Windows machine.
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E Insert the DVD into the DVD drive of the computer on which youwant to install the license manager
tools. Launch \Windows\Administration\Licensing\NetworkLicenseManager\Tools\setup.exe on
the DVD.

or

E If you downloaded the license manager, use an archive utility such as WinZip to extract the
contents of the downloaded file. Launch the setup.exe file.

E Follow the instructions that appear on the screen.

Licensing Your Product
After the main part of the installation is complete on Windows, click Finish to launch the License
Authorization Wizard. The License Authorization Wizard allows you to obtain a license for IBM®
SPSS® Statistics. On other operating systems, you must install the license from the command
prompt after installing the license manager.

If you do not get a license now, you can enable SPSS Statistics to be used for a temporary usage
period by a limited number of users. For IBM® SPSS® Statistics, all add-on modules are enabled.
For IBM® SPSS® Statistics Developer, only the Core system is enabled. After the temporary
usage period—which begins when the product is first used—SPSS Statistics will no longer run.
Therefore, it is recommended that you obtain a license as soon as possible. You must either obtain
a license or enable for temporary usage to use SPSS Statistics.

Note: Licenses are tied to the network computer’s hardware with a lock code. If you replace the
network computer or its hardware, you will have a new lock code and will need to contact your
sales representative to obtain a new authorization code.

Warning: The license is sensitive to time changes. If you must change the system time and then
cannot run the product, contact SPSS Inc. Technical Support.

Using the License Authorization Wizard (Windows Only)

Note: If you are running Windows Vista, you may be prompted for administrator credentials.
Without the correct credentials, you will not be able to run the License Authorization Wizard.

The License Authorization Wizard is available only on Windows. If you need to license the
license manager on a different operating system, you must license from the command prompt. For
more information, see the topic Installing a License from the Command Prompt on p. 6 .

E If you don’t launch the License Authorization Wizard during installation or cancel the License
Authorization Wizard before obtaining a license, you can launch it by running law.exe, which
can be found the license manager installation directory. On Windows Vista or 7, you must run as
administrator. Right-click law.exe and choose Run As Administrator.

E When prompted, choose License my product now.

E When prompted, enter one or more authorization codes. If you received a physical copy of the
installation media, authorization codes are delivered along with your software on a separate
sheet of paper or on the inside cover of the DVD case. Authorization codes are delivered
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along with your software on a separate sheet of paper. If you downloaded IBM® SPSS®
Statistics, your authorization code is available in your Asset Management Portal or from
http://www.ibm.com/software/getspss. You should have received the authorization code(s) from
your administrator.

The License Authorization Wizard sends your authorization code over the Internet to SPSS Inc.
and automatically retrieves your license. If your computer is behind a proxy, click Configure

proxy settings and enter the appropriate settings.

If the authorization process fails, you will be prompted to send an e-mail message. Choose
whether you want to send the e-mail message through your desktop e-mail program or through a
Web-based e-mail application.

If you choose the desktop option, a new message with the appropriate information will be
created automatically.
If you choose the Web-based option, you must first create a new message in your Web-based
e-mail program. Then copy the message text from the License Authorization Wizard and
paste it into your e-mail application.

Send the e-mail message and respond to the prompt in the License Authorization Wizard. The
e-mail message will be processed almost instantaneously. You can click Enter License Code(s)

to enter any license code(s) that you receive. If you already closed the License Authorization
Wizard, restart it and select License my product now. On the Enter Codes panel, add the license
code that you received and click Next to complete the process.

Installing a License from the Command Prompt

You have two options for installing from the command prompt. You can use licenseactivator to
get a license from the Internet automatically, or you can use echoid to get a license manually.

Using licenseactivator to Install a License Automatically

The computer on which you are installing the license must be connected to the Internet. If it isn’t,
install the license manually. For more information, see the topic Installing a License Manually
on p. 7 .

E Log in as the user who installed the license manager.

E Open a command prompt and change directories to the license manager installation directory. Note
that this is the directory in which you installed the license manager, not the directory in which you
installed IBM® SPSS® Statistics. If you accepted the default location on Windows, check the
C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder.

E Windows Only. Change directories to the winnt subdirectory.

E You typically have an authorization code. In the simplest case, you enter the following at the
command prompt. See below for more details about the command prompt usage.

licenseactivator <auth-code>

http://www.ibm.com/software/getspss
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where <auth-code> is your authorization code.

You should see a message that the license was added successfully. If it wasn’t, note the error code
and try installing the license manually. For more information, see the topic Installing a License
Manually on p. 7 .
When you use licenseactivator, it licenses the product and writes a log file to its directory.

The name of the log file is licenseactivator_<month>_<day>_<year>.log. If any errors occur,
you can check the log file for more information. This information is also useful if you contact
SPSS Inc. for support.

Using licenseactivator with Authorization Codes

licenseactivator is typically used with one or more authorization codes that you received when
you purchased the product. Enter all of the text on one line.

licenseactivator authcode1[:authcode2:...:authcodeN] [PROXYHOST=proxy-hostname]
[PROXYPORT=proxy-port-number] [PROXYUSER=proxy-userid] [PROXYPASS=proxy-password]

Multiple authorization codes are separated by colons (:).
The proxy settings are optional, but you may need them if your computer is behind a proxy.
Which proxy settings are needed depend on the operating system.
Windows. On Windows, the proxy settings work only when the Local Area Network (LAN)
settings in the Internet Settings control panel reference a specific proxy server (host) address
and port. You do not enter the proxy host and port on the command line. But you do need to
enter values for PROXYUSER and PROXYPASS.
Other Operating Systems. On other operating systems, you may need to enter all of the proxy
settings on the command line, depending on your specific proxy configuration.

Using licenseactivator with License Codes

In less common scenarios, SPSS Inc. may have sent you a license.

licenseactivator licensecode[:licensecode2:...:licensecodeN]

Multiple license codes are separated by colons (:).
When using license codes, licenseactivator does not connect to the Internet, so you do not
need to specify proxy information.

Installing a License Manually

E Log in as the user who installed the license manager.

E Open a command prompt and change directories to the license manager installation directory. Note
that this is the directory in which you installed the license manager, not the directory in which you
installed IBM® SPSS® Statistics. If you accepted the default location on Windows, check the
C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder.

E Windows Only. Change directories to the winnt subdirectory.
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E Get the lock code for the server machine. At the command prompt, type echoid (other operating
systems) or ./echoid (UNIX).

E Send the lock code and your authorization code to SPSS Inc. by calling your local office or
sending an e-mail message to spsscs@us.ibm.com. SPSS Inc. will then provide a license code
or a file containing a license code.

E Use licenseactivator to enter the license code or codes.

Enabling for Temporary Usage

If you did not install the license, you can enable IBM® SPSS® Statistics for temporary usage.

E Make sure that the DVD is in the DVD drive.

E Start the WlmAdmin application. For more information, see the topic Starting the WlmAdmin
Application on p. 15.

E In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers. If the
license manager server is not listed, specify the computer by choosing Defined Server List from
the Edit menu.

E Right-click the name of the network computer on which the license manager is running and choose:
Add Feature > From a File > To Server and its File

Note: If you select To Server rather than To Server and its File, the temporary usage information is
stored in memory. You will lose this information when the network computer is rebooted.

E In the Open dialog box, type
D:\Windows\Administration\Licensing\NeworkLicenseManager\lservrc.temp, where D
is your installation disk drive. If you are not using D for the disk drive, enter the
appropriate drive location.

E When the application displays your license, click OK. For information about viewing the license’s
details, see Viewing Details about a License on p. 16.

Adding a License

You may want to add a license at a later time. The process for adding a license is the same as
installing the original license.

Viewing Your License

You can view your network license (including the number of users) in the WlmAdmin application.
For information about the WlmAdmin application and specifics about viewing the license, see
Administering the Network License on p. 15.
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Testing the License Manager
To make sure the license manager is serving up licenses correctly, you should test it.

E If you haven’t installed the license manager tools on another machine, install them on a Windows
machine that is not running the license manager you want to test. For more information, see the
topic Installing the License Manager Tools on p. 4 .

E Start the WlmAdmin application. For more information, see the topic Starting the WlmAdmin
Application on p. 15.

E Add the remote license manager server that you want to test. For more information, see the
topic Adding a Server on p. 15.

E View the licenses on the remote server. For more information, see the topic Viewing Details
about a License on p. 16.

If you are able to view the license, the license manager is ready for local desktop computers to
connect to it. You can proceed with installing the product on local desktop computers. If you are
not able to view the license, review the previous steps to ensure the license manager was installed
correctly.

Installing the Product on the Local Desktop Computers
Note: We do not officially support connecting to the network license manager through VPN.

You have two options for installing the full product locally on an end user’s computer. You can
manually install on each computer, or you can use an application like Systems Management
Server (SMS) to push the installation to the computers running Windows. You also have the
option of running a silent installation on Mac and Linux.

To Manually Install on a Local Desktop

E Make the installation media available. Make as many copies of the DVD as you need or place it
on a shared network drive.

E Copy the installation instructions and prepare licensing information. Make as many copies
of the product installation instructions as you need. The installation instructions are in the
/Documentation/<language>/InstallationDocuments directory on the DVD in Network License
Installation Instructions.pdf. You may want to distribute the abbreviated installation instructions.
These can be found in Network License Installation Instructions (Abbreviated).pdf. If you
downloaded the software, all the instructions are available from your Asset Management Portal
or from http://www.ibm.com/software/getspss. After installation, the end user must enter the IP
address or the name of the network computer on which the network license manager is running.
Fill out this information in the space provided at the beginning of the instructions before copying
them.

E Distribute the installation materials to end users. Distribute the installation DVD (or downloaded
file or network location), the installation instructions, and the licensing information to end users
who can manually install on each computer as needed.

http://www.ibm.com/software/getspss
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To Push to the Local Desktops Running Windows

Because IBM® SPSS® Statistics installations are compatible with Microsoft Windows Installer
(MSI), you can push an installation to the end-user desktop computers.

Pushing an Installation to Windows Computers

Pushing an installation is a method for remotely distributing software to any number of end users
without any user intervention. You can push the full installation of IBM® SPSS® Statistics to the
end-user desktop computers running Windows. The technology that you are using for pushing the
installation must support the MSI 3.0 engine or higher.

Note: Pushing an installation is not directly available for Mac and Linux. Instead, you can run a
silent installation. For more information, see the topic Running a Silent Installation on Mac and
Linux Computers on p. 14.

Uninstalling a Previous Version

If you are going to push to the same directory in which a previous version of IBM® SPSS®
Statistics was installed, you need to uninstall the old version.You can push the uninstallation as
you push an installation. For more information, see the topic Pushing an Uninstallation on p. 13.

Properties for Push Installations

Following are the properties that you can use for push installations. All properties are case
sensitive. Values must be quoted if they contain spaces.
Table 1-1
Properties for Push Installations

Property Description Valid value(s)
INSTALLDIR The directory where IBM®

SPSS® Statistics should be
installed on the end user’s
desktop computer. This property
is optional. If it is excluded,
the default is C:\Program
Files\IBM\SPSS\Statistics\19.

A valid path such as C:\Statistics.

LICENSETYPE The license type. The value is
case sensitive.

Network

LSHOST The IP addresses or the names
of the network computer or
computers on which the network
license manager is running.

One or more valid IP addresses
or network computer names.
Multiple addresses or names are
separated by colons (for example,
server1:server2:server3).



11

Network License Administrator’s Guide

Property Description Valid value(s)
DISABLE_COMMUTE Disables the commuter license

functionality on the end user’s
desktop computer. If this property
is specified, no shortcuts for
the commuter license will
be installed on the desktop
computer. For more information
about commuter licenses, see
Configuring Commuter Licenses
on p. 18.

1, which indicates that commuter
licenses are disabled.

SPSS_COMMUTE_MAX_LIFE The maximum number of days
for which an end user can
check out a commuter license.
For more information, see the
topic Configuring Commuter
Licenses on p. 18.

A number between 1 and 30.

HELPCHOICE A value indicating the help
language. You can choose to
install help in all languages or
one specified language. The value
is ALL or a code indicating the
specific language. The default
is en or the language specified
by the TRANSFORMS property.
For more information, see the
topic Pushing the Installation to a
Non-English System on p. 13.
The valid values column lists
the codes. The language
associated with the code appears
in parentheses next to the code
itself.

ALL (All languages)
de (German)
en (English)
es (Spanish)
fr (French)
it (Italian)
ja (Japanese)
ko (Korean)
pl (Polish)
ru (Russian)
zh_CN (Simplified Chinese)
zh_TW (Traditional Chinese)

COMPANYNAME The name of your company. Any string.

MSI Files

The IBM SPSS Statistics 19.msi file is located under the Windows\SPSSStatistics\<architecture>
directory on the DVD, where <architecture> is 32bit or 64bit. If you downloaded the software,
you must extract the contents of the installer file to access the MSI file. For more information, see
the topic Extracting the Contents of a Downloaded Installer File on p. 11.

Extracting the Contents of a Downloaded Installer File

If you did not receive the installation DVD and instead download IBM® SPSS® Statistics, you
downloaded a single installer file. You cannot push this file directly. You first need to extract the
contents of the file and use those contents for the push installation.

E Open a command prompt.

E Change directories to the directory in which the downloaded file is located.

E Execute the downloaded file with the /b switch. After the switch, identify the directory in which
you want to extract the contents of the file. There is no space between the switch and the directory
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name. If the directory name contains spaces, it must be enclosed in quotes. Following is an
example (your executable name will not match the example):

ProductInstaller.exe /b"C:\temp\extracted files\SPSS Statistics"

E When the first panel of the installation appears, cancel the installation.

The files that you need for pushing the installation are now in the directory specified by the
/b switch.

Command Line Example

Following is a command line that you could use to push a product installation. Enter all of the
text on one line.

MsiExec.exe /i "IBM SPSS Statistics 19.msi" /qn /L*v logfile.txt
INSTALLDIR="C:\Statistics" LICENSETYPE="Network" LSHOST="mylicserver"

Using SMS to Push the Installation

The basic steps for using Systems Management Servers (SMS) to push IBM® SPSS® Statistics
are:

E Copy the appropriate subdirectory under the Windows\SPSSStatistics\<architecture> directory on
the DVD to a directory on a network computer. If you downloaded the software, you cannot push
with SMS. Try another option. For more information, see the topic Using Group Policy or Related
Technology to Push the Installation on p. 12.

E Edit the IBM SPSS Statistics 19.sms file located in the copied directory. Using a text editor,
modify the value of CommandLine by adding the appropriate properties. For a list of the available
properties, refer to Properties for Push Installations on p. 10. Make sure to specify the correct
MSI file in the command line.

E Create a package from the IBM SPSS Statistics 19.sms file and distribute the package to the
end-user desktop machines.

Using Group Policy or Related Technology to Push the Installation

The basic steps for using Group Policy or a related technology to push IBM® SPSS® Statistics are:

E Copy the appropriate subdirectory under the Windows\SPSSStatistics\<architecture> directory
on the DVD to a directory on a network computer. If you downloaded the software, you must
first extract the contents of the installer file. For more information, see the topic Extracting the
Contents of a Downloaded Installer File on p. 11.

E Using an application like ORCA, edit the Properties table in the appropriate IBM SPSS Statistics
19.msi file under the copied folder. ORCA is part of the Windows 2003 Server SDK, which
you can find at http://www.microsoft.com/downloads by searching for the SDK. For a list of the
properties that you can add to the Properties table, refer to Properties for Push Installations on
p. 10. Make sure to use the correct MSI file.

http://www.microsoft.com/downloads
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E Create a package using the edited IBM SPSS Statistics 19.msi file and distribute the package
to the end-user desktop computers.

Pushing the Installation to a Non-English System

You can push to a non-English system without additional specification. However, the installer
language (if pushing an interactive installation) will appear in English, the user interface will
appear in English, and the help will appear in English. Users can change the user interface
language after installation, but localized help will not be available.

If you are pushing from the DVD, you can use the TRANSFORMS property to specify one of the
MST files available on the DVD. The MST file will ensure the installer, user interface, and help
appear in the specified language. MST files are not available if you downloaded IBM® SPSS®
Statistics. Users will need to manually install the language packs for the localized help and
manually change the user interface language in the product.

The TRANSFORMS property is a parameter for MsiExec.exe. The following example uses the
TRANSFORMS property to push a French installation. The installer will appear in French, the user
interface will appear in French, and French help will be installed. (You can also override the help
language with the HELPCHOICE property. For more information, see the topic Properties for Push
Installations on p. 10.) Enter all of the text on one line.

MsiExec.exe /i "IBM SPSS Statistics 19.msi" /qn /L*v logfile.txt
INSTALLDIR="C:\Statistics" LICENSETYPE="Network" LSHOST="mylicserver" TRANSFORMS=1036.mst

The following language MST files are located in the Windows\SPSSStatistics\<architecture>
directory on the DVD, where <architecture> is 32bit or 64bit.
Table 1-2
Language MST Files

Language MST File
English 1033.mst
French 1036.mst
German 1031.mst
Italian 1040.mst
Japanese 1041.mst
Korean 1042.mst
Polish 1045.mst
Russian 1048.mst
Spanish 1034.mst
Simplified Chinese 2052.mst
Traditional Chinese 1028.mst

Pushing an Uninstallation

Note: When you push the uninstall command, the end user loses customizations. If specific
users require customizations, you can exclude those users from the distribution and ask them to
install the product manually.
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If you push an installation of a later version of IBM® SPSS® Statistics, you may want to uninstall
first. You can do this silently by pushing the following command. Enter all of the text on one line.

MsiExec.exe /X{06C43FAA-7226-41EF-A05E-9AE0AA849FFE} /qn /L*v logfile.txt
ALLUSERS=1 REMOVE="ALL"

This command will uninstall SPSS Statistics 19. The following table lists the uninstall IDs for
this and previous releases.
Table 1-3
Uninstall IDs for IBM SPSS Statistics

Version Uninstall ID
19.* {06C43FAA-7226-41EF-A05E-9AE0AA849FFE}
18.* {C25215FC-5900-48B0-B93C-8D3379027312}
17.0.2 {2ECDE974-69D9-47A9-9EB0-10EC49F8468A}
17.0.1
17.0.0

{46B65150-F8AA-42F2-94FB-2729A8AE5F7E}

16.* {621025AE-3510-478E-BC27-1A647150976F}

Running a Silent Installation on Mac and Linux Computers

A silent, unattended installation does not display a graphical interface and does not require any
user intervention. The DVD includes an installer properties file that allows you to run this sort
of installation on Mac and Linux. The file contains several different options and descriptions
of these options.

How to Use the Installer Properties File

The installer properties file, installer.properties, can be found in /Linux/Administration or
/MacOS/Administration at the root of the DVD.

E Copy the installer properties file from the DVD.

E Open the copied file in a text editor.

E Change the properties that you need. Some options require a string value, while others that
correspond to choices in the installer can be set to 0 (off) or 1 (on).

How to Run the Silent Install

E Using a terminal application, run the installation executable with the -f switch followed by the
location of the options file surrounded by quotation marks. You must run as root or with the sudo
command. Following is an example on Linux:

sudo ./setup.bin -f "/root/installer.properties"

The installation executable for each operating system can be found on the DVD in the following
location:

Mac OS. /MacOS/Administration/SPSS Statistics_Installer_Silent.bin
Linux. /Linux/setup.bin
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Administering the Network License

The license manager maintains your network license. To administer the license manager itself and
to view information about the network licenses that it is maintaining, you can use the WlmAdmin
application, which is the main user interface for the license manager tools. The license manager
tools are installed automatically with the network license manager on Windows. If you are
administering a license manager on a non-Windows machine or a remote Windows machine,
install the license manager tools on a separate Windows machine. For more information, see the
topic Installing the License Manager Tools on p. 4 .

Note: If you need additional administration information, refer to the Sentinel documentation, which
is located in <operating system>\Administration\Licensing\NetworkLicenseManager\SentinelLM
Help on the DVD. This documentation is also installed with the license manager on Windows.

Starting the WlmAdmin Application

From a Windows Computer where the License Manager is Installed

E From the Windows Start menu, choose:
[All] Programs > Sentinel RMS License Manager > Sentinel RMS Server Administration

From a Windows Computer where the License Manager Tools are Installed

E From the Windows Start menu, choose:
[All] Programs > Sentinel RMS Tools > Sentinel RMS License Server Administration

Adding a Server

Before you can administer a network license manager, you need to add its server to the WlmAdmin
application. You have two options for adding the server.

To Manually Add a Server

E From the WlmAdmin application menus, choose:
Edit > Defined Server List

E In the Defined Server List dialog, enter the name or IP address of the server on which the license
manager is running.

E Click Add.

E Click OK.

The server now appears in the Defined Servers lists in the left pane of the WlmAdmin application.

To View a List of Servers on the Subnet

E In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers.
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A list of network license manager servers on your subnet appears. If you can’t find a specific
server with this method, manually add it as described above.

Setting the Location of the Log File

If end users have difficulty checking out licenses, the log file may contain useful information. To
change the location of the log file or to find out where it is currently located, follow these steps:

E In the left pane of the WlmAdmin application, right-click the network license manger server and
choose Change Log Filename from the shortcut menu. A dialog box appears.

E Change the filename if necessary. In the New File Name text box, type the full file specification of
the license manager’s log file for that network computer.

E If you made changes, click Change. Otherwise, click Cancel.

Viewing Details about a License

You can view details about licenses that you added either manually or through the License
Authorization Wizard.

E In the left pane of the WlmAdmin application, click the + sign next to the license manager server
to see the license(s).

E Click the name of the license. The right pane displays details about the license. Codes are used to
identify the licenses. The first part of the code indicates the feature. The second part indicates
the version.

To See the Names Associated with the Feature Codes

E Using a command prompt, change to the directory in which the license manager or the license
manager tools are installed.

E Type lmshowlic <server> (Windows) or ./lmshowlic <server> (other operating systems), where
<server> is the name or IP address of the server on which the license manager is running.

The output lists all the features available on the server, grouped by product and version.

Setting Up Redundant License Servers

You can set up multiple, redundant license servers that support the same users. Redundant servers
can help prevent any interruption that may occur when a server crashes. Another redundant server
can take over the management of the license when the first server crashes.
You will need a special authorization code to enable the redundancy feature. The authorization

code shipped with the software will not enable redundancy. Be advised that by installing the
code that ships with the software, you will forfeit your ability to use the redundancy feature. If
you wish to enable redundancy, complete the preparation steps described below. Then contact
Customer Service at spsscs@us.ibm.com or call (800) 521-1337 between 8:30 A.M. and 5:00 P.M.
U.S. Central Time. For customers outside of North America, please contact your local office.
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There must be an odd number of servers (at least three of them), and a majority must be
running at the same time. For example, if there are three redundant license servers, two of them
must be running.

To Prepare Each Redundant License Server

E Install the license manager. For more information, see the topic Installing the Network License
Manager on p. 2 .

E Using a command prompt, change to the directory in which you installed the license manager.

E Get the lock code for each server machine. At the command prompt, type echoid (Windows) or
./echoid (other operating systems).

E Write down the lock code. You will need this when you contact Customer Support or your local
office.

E Repeat these steps for each redundant license server.

To Set Up the Redundant License Server Pool

E If a license manager is running on any of the redundant license servers, stop the license manager
on each computer.

E From the WlmAdmin application menus, choose:
Edit > Redundant License File

This action opens the WrlfTool application.

E From the WrlfTool application menus, choose:
File > New

E For each redundant license server, click Add to specify the hostname and IP address of each server.

E Change the order of the servers to indicate the order in which the redundant license servers are
used. The first one in the list is the primary server.

E Click Add License to add the license(s) that you received from Customer Service or your local
office. If you received multiple licenses, be sure to add every one.

E Click OK.

E Click Done when you are finished.

To Save the Redundant License File

E From the WrlfTool application menus, choose:
File > Save As

E Save the redundant license file (lservrlf) to an easily accessible location. You will need to copy the
file in the next steps.
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To Configure the Redundant License Servers

E Copy the redundant license file (lservrlf) to the winnt subfolder of the license manager installation
directory on Windows. If you accepted the default location, check the C:\Program Files\Common
Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder. On other operating systems,
copy the file directly to the license manager installation directory. There must be at least three
redundant license servers.

E Start the license manager on each redundant license server.

To Configure End-User Computers

When the end user installs the product, the user specifies all redundant servers, with the server
names or IP addresses separated by a colon (for example, server1:server2:server3). The setup
program then adds the necessary configuration information to the end user’s computer. If the
product is already installed on the desktop computers, you can perform the following manual steps
to add the configuration information. You can also push an uninstall followed by a new install
that defines all the servers. Refer to Pushing an Installation to Windows Computers on p. 10
for information about pushing installations.

E Using a text editor, open spssprod.inf, which is located in the product installation directory on
the desktop computer.

E Comment out the line for DAEMONHOST. For example:

#DAEMONHOST=server1

E Save spssprod.inf.

E Create an LSHOST environment variable. Set this variable to include all redundant servers, with
the server names or IP addresses separated by a colon (for example, server1:server2:server3).
On Mac and Linux, you can store this environment variable in the statsenv.sh script. For more
information, see the topic Defining Environment Variables on End Users’ Computers on p. 23.

Configuring Commuter Licenses

Commuter licenses allow your end users to check out licenses from the license manager, so that
they can use the license when not connected to the network. On Windows, commuter licenses are
not enabled by default. They are enabled by default on other operating systems. Instructions for
actually checking out the commuter license appear in the end user installation instructions.
You can restrict the percentage of licenses that are enabled for commuting on the license

manager server. It’s a good idea to restrict commuter licenses to prevent all the licenses (tokens)
from being used up by commuters. After the specified percentage of licenses have been used by
commuters, no more will be available until the commuter licenses expire or are checked back
in. You can also configure the maximum duration for which an end user can check out a license.
The default maximum duration is seven days.
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To Set the Percentage of Available Commuter Licenses

E Create an LSERVOPTS environment variable on the license manager server. This variable is
created during the license manager installation on Windows, so you need to complete this only for
the other operating systems.

E Edit the value of the LSERVOPTS environment variable to include -com <percentage>, where
<percentage> is a numeric value between 0 and 100 indicating the percentage of licenses that are
available for commuting. Specifying 0 disables commuter licenses. This switch is included by
default on Windows and is set to 0.

E Restart the computer on which the license manager is running.

To Set the Maximum Duration for Commuter Licenses

The maximum length of time a user can check out a commuter license is specified by the
CommuterMaxLife setting in the spssprod.inf file on the desktop. computer. This file is located
in the product installation directory on the desktop computer. Open spssprod.inf and look for
CommuterMaxLife . Set the value of this option to the maximum number of days for which an
end user can check out a commuter license. This should be a number between 1 and 30. You can
also set this value when you push the installation. For more information, see the topic Pushing an
Installation to Windows Computers on p. 10.

Note: This functionality works off the date, not the time. For example, if you set the
CommuterMaxLife option to one day, then check a license out at 9 a.m., this license does not get
checked back in until midnight on the following day. So although CommuterMaxLife is set to
one day, the license is actually held for 39 hours.

To Obtain a List of Checked Out Licenses from the Command Line

You can find out which users have checked out licenses.

E Using a command prompt, change to the directory in which the license manager or the license
manager tools are installed.

E Type lsmon <server> (Windows) or ./lsmon <server> (other operating systems), where <server>
is the name or IP address of the server on which the license manager is running. You can omit the
license server name if you want to view checked out licenses for only the localhost server.

To Obtain a List of Checked Out Licenses from the WlmAdmin Application

You can also view checked out licenses in the WlmAdmin application:

E In the left pane of the WlmAdmin application, click the + sign next to the license manager server.

E Click the + sign next to Clients. Clients using the network license are listed. If no clients are
listed, no users are using the network license.

E Select a particular Client to view whether the client has a checked out license. Review the Detailed
Information area in the right pane after selection.
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Configuring License Reservations

You can create a reservation file, which specifies how many licenses are reserved for specific users
or groups of users. Users are identified by network IDs or computer names (not IP addresses). For
example, you can set up a reservation file that reserves the license for a group of power users.
Licenses will always be available for these users. You can also use the reservations to prevent
certain users from accessing the license.

To Create a New Reservation File

E From the WlmAdmin application menus, choose:
Edit > Reservation File

This action opens the Wlsgrmgr application.

E From the Wlsgrmgr application menus, choose:
File > New

To Add Licenses and Users to the Reservation File

E From the Wlsgrmgr application menus, choose:
Feature > Add

E Click Next on the first screen of the wizard.

E Specify the feature code associated with the license that you want to reserve. Refer to Viewing
Details about a License on p. 16 for information about getting the feature codes associated
with licenses. Also define a specific version, which is entered as it appears in the WlmAdmin
application (for example, 160). The version is not optional. Ignore the Capacity controls, because
capacity licenses are not supported.

E Click Next.

E Specify a name for a group of users. The name is arbitrary, but you should make it descriptive
(for example, Sales).

E Specify the number of licenses that are reserved for the group. Group members can still access all
licenses, but the number of licenses you specify will no longer be available for users who are not
included in the group. That is, if you have 10 licenses and you reserve five, members of the group
have 10 licenses available to them, while other users have only five.

E On the Members window, click Add to specify a user or computer name associated with the
group (do not use IP addresses). If the user or machine is included in the group, that user or
machine can use the reserved license. If the user or machine is excluded from the group, that
user or machine cannot access the license at all. Specify as many users or machines as needed.
Note that groups must be mutually exclusive. Therefore, different groups for the same license
cannot contain common users or computers.

E Click Finish when all users have been added to the group.

E Add other groups or licenses as needed. You can also modify or delete licenses and groups by
right-clicking one and choosing Properties.
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To Save the Reservation File

E When finished defining the reservation file, from the menus choose:
File > Save As

E Save the file to an easily accessible location. You will need to copy the file in the next step.

E To enable the license server to automatically find the lsreserv file at start up, copy the file to the
winnt subfolder of the license manager installation directory on Windows. If you accepted the
default location, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder. On other operating systems, copy the file directly to the license manager
installation directory.

E If you want the same reservations to apply for all redundant servers, copy the reservation file
(lsreserv) to each server.

E Restart each license manager when finished.

Starting and Stopping the License Manager

The method for starting the license manager depends on your operating system.

Windows

On Windows machines, the license manager is a System Service. The service is automatically
started by default. However, if you need to start it manually:

E In the Windows Control Panel, double-click Administrative Tools.

E Double-click Services.

E Locate Sentinel RMS License Manager in the Services list.

E Right-click the service and choose Start or Stop.

Other Operating Systems

On other operating systems, the license manager is a daemon service. Complete the following
steps to start it manually. You can also configure the license manager to start automatically
(instructions follow).

E Using the command prompt, browse to the directory in which you installed the license manager.

E Starting. As root, type ./lserv & at the command prompt and press Enter.

E Stopping. As root, type ./lsrvdown <hostname> at the command prompt, where <hostname> is the
network name of the computer on which the license manager is running. Then press Enter.
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Configuring the License Manager to Start Automatically

Windows

E In the Windows Control Panel, double-click Administrative Tools.

E Double-click Services.

E Locate Sentinel RMS License Manager in the Services list.

E Right-click the service and choose Properties.

E Set the Startup type to Automatic.

E Click OK.

Other Operating Systems

E Add ./lserv & to one of the operating system startup files.

Uninstalling the License Manager

Windows

E From the Windows Start menu, choose:
Settings > Control Panel

E Double-click Add/Remove Programs.

E Select Sentinel RMS License Manager and then click Remove.

E Click Yes when prompted to remove the license manager.

Other Operating Systems

E Using the command prompt, browse to the directory to which you installed the license manager.

E As root, stop the license manager by typing ./lsrvdown <hostname> at the command prompt,
where <hostname> is the network name of the computer on which the license manager is running.
Then press Enter.

E Remove the directory where the license manager is installed.

Troubleshooting Desktop Computers

If the end users’ desktop computers are having trouble finding the license manager:

E Run lswhere to verify that the desktop computer can find the network computer on which the
license manager is running. For more information, see the topic Running lswhere on p. 23.

E Make sure the license manager service is running on the network computer.
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E Check the appropriate spssprod.inf file. This file is located in the product installation directory
on the desktop computer. Open spssprod.inf and make sure DAEMONHOST is set to the correct
name or IP address of the computer on which the license manager is running. If you are using
redundant servers, this should be blank.

E If you are using redundant servers, make sure the LSHOST environment variable defines all of them.
Each name is separated by a colon (:) character. For example, if the license manager computers
are SERVER1, SERVER2, and SERVER3, LSHOST is set to SERVER1:SERVER2:SERVER3.
On Mac and Linux, you can store this environment variable in the statsenv.sh script. For more
information, see the topic Defining Environment Variables on End Users’ Computers on p. 23.

Running lswhere

You can run lswhere from an end user’s desktop computer to check which computer is running the
network license manager.

E Using a command prompt, change the current directory to one of the following:
Windows. <installation directory>
Mac OS. <installation directory>/<product>.app/Contents/bin
Linux. <installation directory>/bin

E Type lswhere (Windows) or ./lswhere (Linux and Mac).

Defining Environment Variables on End Users’ Computers

The following instructions are for defining environment variables on end users’ computers.

To Define an Environment Variable on Windows 2000/Windows XP/Windows 2003

E In the Windows Control Panel, double-click System.

E Click the Advanced tab.

E Click Environment Variables.

E In the System Variables area of the tab, click New.

E In the Variable Name text box, type LSHOST.

E In the Variable Value text box, type the name or IP address of the computer on which the license
manager is running—for example, myserver or 204.171.64.2.

E Click OK.
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To Define an Environment Variable on Linux and Mac OS

Environment variables for IBM® SPSS® Statistics are stored in the statsenv.sh script file. This
file is called by other script files, including the one that launches the application. You can find
statsenv.sh in one of the following locations:

Mac OS. <installation directory>/<product>.app/Contents/MacOS
Linux. <installation directory>/bin

E Open the script file in a text editor.

E If the environment variable is not already defined in the file, add a line like the following:

export <var name>='<var value>'

where <var name> is the variable’s name and <var value> is the variable’s value. For
example:

export LSHOST='myserver1:myserver2'

E Save and close the script file.

Service and Support
To contact SPSS Inc. Technical Support, visit http://support.spss.com and submit a case. You will
need to register with SPSS Inc. Technical Support if you haven’t done so previously.

SPSS Inc. provides public training seminars for SPSS Inc. products on a regular basis. You can
also arrange to have training presented onsite. For information on training seminars, software, and
publications, call (800) 543-9263 or visit our Web site at http://www.spss.com.

To obtain replacements for faulty media, call Customer Service at (800) 521-1337 between the
hours of 8:30 A.M. and 5:00 P.M. U.S. Central Time, or send an e-mail to spsscs@us.ibm.com.

http://support.spss.com
http://www.spss.com
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